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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates the procedure has
only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown (e.g., “copy
file1 ” means type the word copy, then type a space, then type file1).

o On-screen prompts and messages, names of options and text fields, and menu
commands. Menu commands are often separated by greater than signs (>) (e.g.,
“Click HFSS > Excitations > Assign >Wave Port).

o Labeled keys from the computer keyboard. For example, “Press Enter ” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics (e.g., “copyfile name” means type the word copy, then type a space, then
type the name of the file).

l The plus sign (+) is used between keyboard keys to indicate that both keys should be
pressed at the same time (e.g., “Press Shift +F1 ” means to press Shift and, while holding
it down, press F1). Always depress the modifier key or keys first (e.g., Shift, Ctrl, Alt, or
Ctrl +Shift), continue to hold it/them down, then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Layout > Interface Ground "

This instruction means click the Interface Ground command from the Layout tab. An
image of the command icon, or a partial view of the ribbon, is often included with the
instruction.
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l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"From the Filemenu, selectOpen Examples" means click the Filemenu and select
Open Examples from the drop-down menu.

l Another alternative is to right-click and select from the shortcut menu. An example of a typ-
ical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means select an object, right-
click, and click an option from the shortcut menu that appears.

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. This information can also be obtained by contacting an Ansys
account manager.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps are taken
or what stages the simulation reached, including software files as applicable. This allows more
rapid and effective debugging.

Help Menu

From the Help menu, select Help and choose from the following:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1 to open the chosen help for the active product.

Press F1 while the cursor is pointing at a menu command or while a particular window tab is
open. In this case, the help page associated with the command or open window is displayed
automatically.
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1 - Introduction
Complete theGetting Started with HFSS 3D Layout: Microstrip Filter guide to create, solve,
and analyze a microstrip bandstop filter using the HFSS 3D Layout design type in the Elec-
tronics Desktop application. A bandstop filter (also known as a band-rejection filter) is a device
that attenuates signals within a target frequency band while passing higher and lower fre-
quencies unaltered. It is the opposite of a bandpass filter.

Note:

This figure was captured with the HFSS 3D Layout> HFSS Extents option enabled. The
outer envelope represents the boundary of the default air box surrounding the model,
which is the extent of the solution region meshed and solved an HFSS analysis is per-
formed.

In the otherGetting Started with HFSS 3D Layout guides (Slot Fed Patch Antenna and Low Pass
Filter) the ground plane layer of the stackup was defined as Negative, and any objects drawn on
that layer represented areas of removed conductor. In this exercise, the ground layer is not Neg-
ative, then draw the ground plane conductor object.

Getting Started with HFSS 3D Layout: Microstrip Filter

Create the Model 1-1
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Draw the model using parametric design variables for the signal layer. Then evaluate and com-
pare the filter response using both HFSS and Planar EM analyses.

Set General Options
Before creating the bandstop filter, follow these steps to ensure the default unit of length meas-
urement is set tomil.

Note:

Define general settings before adding an HFSS 3D Layout Design element to a pro-
ject. The general options control the default settings when the design type is added. To
change default settings after a design has been added to the project, from the Layout
tab, select Layout Settings.

1. Open theOptions window by doing one of the following:

l From the Desktop ribbon, clickGeneral Options.

Create the Model 1-2
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l From Tools, selectOptions > General Options.

Create the Model 1-3
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2. If appropriate, expand theGeneral group.

Create the Model 1-4
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3. Select Default Units.

Create the Model 1-5
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4. Selectmil from the Length drop-down menu.

5. ClickOK to close theOptions window.

Enabling Legacy View Orientation
The instructions and examples in this guide use the legacy view orientation scheme, rather than
the controls introduced in release 2024 R1. Complete these steps to enable the Legacy View
Orientation and avoid any confusion.

Create the Model 1-6
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1. Navigate to Tools >Options > General Options to open the 3D UI Options window.

2. ExpandGeneral and select User Interface.
3. Check the Enable Legacy View Orientation box. When the user has completed theGet-

ting Started Guide, they should return toOptions window and uncheck the Enable
Legacy View Orientation box.

Create the Model 1-7
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4. ClickOK.

Model Diagram
The following figure is a diagram of the Trace (signal) layer of the microstrip bandstop filter
model:

Create the Model 1-8
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There is also a 150 x 50 mil rectangular ground plane conductor that can be drawn on a separate
layer.

Continue to Inserting Layers.
.

Inserting Layers
Complete these steps to insert layers in an HFSS 3D Layout design.

1. From the Layout tab, click the Layers dialog button to open the Edit Layers window.

Create the Model 1-9
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Note:

Alternatively, from Layout, select Layers.

2. In the Edit Layers window > Stackup area, selectOverlapping from the Type drop-
down menu.

Create the Model 1-10
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Add a Ground Layer to the Grid Control Table

Note:

When adding the first layer to the Grid Control Table, the actions of Insert above and
Insert below are identical. Once there are one or more layers in the table, the Insert
above and Insert below options will be inactive until a layer is selected from the table.
After selecting a layer from the table, select the chosen option depending on where you
would like the new layer to appear in the table (i.e., above or below).

1. Click Layer and select either Insert above or Insert below to open the Add Stackup
Layer window.

2. In the Add Stackup Layer window, do the following:

Create the Model 1-11
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a. EnterGND in the Name field.
b. ClickOK to close the Add Stackup Layer window add the new ground layer to the

Grid Control Table.

Note:

The material copper is automatically assigned to signal layers.

Add a Dielectric Layer to the Grid Control Table

1. Right-click anywhere in theGND layer and select Insert dielectric above. A new row
appears in the Grid Control Table (default Name, Dielectric).

2. In the new dielectric row, do the following:
a. In the Name field, replace Dielectric with Sub1.
b. Ensure 5mil is entered in the Thickness field.
c. Select Edit from theMaterial drop-down menu to open the Select Definition win-

dow.

Create the Model 1-12
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3. In the Select Definition window, do the following:
a. Click Add Material to open the View / Edit Material window.
b. EnterMy_Alumina in theMaterial Name field.
c. Enter 9.9 in the Relative Permittivity field.

Create the Model 1-13
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d. ClickOK to save changes, close the View / Edit Material window, and return to the
Select Definition window.

e. ClickOK to close the Select Definition window.

Create the Model 1-14
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Add a Trace (Signal) Layer to the Layer Grid Control Table

1. Right-click the Sub1 layer and select Insert signal above. A new row appears in the Grid
Control Table.

2. In the new signal row, replace Signal in the Name field with Trace.

Make Changes to All Layers

1. With the Trace layer selected, hold Ctrl and click the first field in theGND row. Both layers
should be highlighted (i.e., selected).

Create the Model 1-15
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Create the Model 1-16
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2. From the Edit selected area, select Edit from theMaterial drop-down menu to open the
Select Definition window.

Create the Model 1-17
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Create the Model 1-18
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3. Select pec (perfect electrical conductor) from the list of library materials. Then clickOK to
close the Select Definition window.

4. From the Layer area, choose Select all from the drop-down menu.
5. Ensure the "shading" box in the Attributes area (i.e., the middle box) is checked. This

ensures that all objects will be shaded, rather than only outlined (i.e., wire frame).

Create the Model 1-19
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Note:

Checking the shading" box ensures that all the objects drawn on each layer is
colored in, as opposed to appearing as only an outline.

Create the Model 1-20
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6. The Edit Layers window should now match the following example.

Create the Model 1-21
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Note:

If the stackup is not arranged in the correct hierarchy, rearrange the layers by
clicking+dragging the selection handles in the left column. The t1 layer should
be from the top of the list, followed by the d1 layer in the middle, and the g1 layer
from the bottom.

7. Click Apply and Close to apply the layer definitions and close the Edit Layers window.

Continue to Drawing the Ground Plane.

Drawing the Ground Plane
Complete these steps to draw a ground plane in the Layout Editor.

1. From the Layout tab, selectGND from the Active Layer drop-down menu.

2. From the Layout tab, click Draw rectangle.

3. Do not click+drag in the Layout Editor. Instead, move the cursor to the X coordinate
field at the bottom of the Layout Editor. Enter 50 in the field.

Create the Model 1-22
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4. Press Tab to move the cursor to the Y coordinate field. Then type 0 in the field and press
Enter.

5. Either press Tab until the cursor moves to the Delta X coordinate field or move the cursor
to the field, click inside it, and enter 150.

6. Press Tab to move the cursor to the Delta Y coordinate field, Then type 50 in the field and
press Enter to complete the ground plane.

Note:

Coordinates entered via the coordinate fields specify opposite corners of a rect-
angle. Alternatively, entering the Center,Width, and Height of the proposed
model in the Properties window determines the dimensions of the model
dependent from the rectangle's centroid.

7. With the new ground plane selected, ensure the 2 pt Description option in the Prop-
erties window is not selected.

8. Enter 50 ,0 in the Center field and press Enter or Tab to relocate the ground plane,
centered at 50, 0.

Create the Model 1-23
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9. Click anywhere else in the Layout Editor to clear the current selection.
10. Zoom In from the space between the right edge of the first rectangle, the top edge of the

second rectangle, and the left edge of the third rectangle, by doing one of the following:
l Spin the mouse wheel to Zoom In/Out.
l Press Ctrl+D.
l From the Layout tab, click Fit All.
l From View, select Fit All.

Create the Model 1-24
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l From the Layout ribbon, select Zoom > Zoom Area. Then click+drag the mouse to
define an area.

11. Click in the Layout Editor's background area to clear the selection. If appropriate, press
Ctrl+D to fit the view.

Continue to Creating L1.

Creating L1
Complete these steps to create the object L1 and then parameterize the object. When an object
is parameterized, variables are defined for the coordinates and dimensions rather than absolute
numeric values. In this way, define additional objects based on parameters of previously defined
ones, to quickly alter the geometry of the model by editing the design parameters. All geometry
directly or indirectly based on an altered parameter is automatically updated.

Create the Model 1-25
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1. From the Layout tab, select Trace from the Active Layer drop-down menu:

2. From the Layout tab, click Draw rectangle.

3. Do not click+drag in the Layout Editor. Instead, move the cursor to the X coordinate
field at the bottom of the Layout Editor. Then enter 0 in the field.

4. Press Tab to move the cursor to the Y coordinate field. Then type 0 in the field and press
Enter.

5. Either press Tab until the cursor moves to the Delta X coordinate field or move the cursor
to the field, click inside it, and enter 96.

Create the Model 1-26
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6. Press Tab to move the cursor to the Delta Y coordinate field, Then type 4.8 in the field and
press Enter to complete the ground plane.

7. Select the new object (i.e., L1) to populate the Properties window. Then make the fol-
lowing changes:

a. Ensure the 2 pt Description option is not selected.

Create the Model 1-27
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b. Enter L1 in theWidth field. Then press Enter or Tab to open the Add Variable win-
dow.

c. Ensuremil is selected from the Unit drop-down menu and 96 is entered in the
Value field. Then clickOK to close the Add Variable window.

Create the Model 1-28
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d. EnterW in the Height field. Then press Enter or Tab to open the Add Variable win-
dow.

e. Ensuremil is selected from the Unit drop-down menu and 4.8 is entered in the
Value field. Then clickOK to close the Add Variable window.

f. Enter L1/2, W/2 in the Center field and press Enter or Tab to accept the coordin-
ates.

Create the Model 1-29
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Continue to Creating Stub 1.

Creating Stub 1
Complete these steps to create the object Stub 1 and then parameterize the object.

Create the Model 1-30
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1. From the Layout tab, click Draw rectangle.

2. Click the lower-left corner of L1 (i.e., 0, 0).

Note:

The cursor changes from a rectangle to a square when a snapping point is detec-
ted.

3. Press Tab to move the cursor to the Delta X coordinate field at the bottom of the Layout
Editor. Then enter 4.8 in the field..

Create the Model 1-31
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4. Press Tab to move the cursor to the Delta Y coordinate field. Then type -4.8 in the field
and press Enter to complete the new rectangle.

5. Select the new object (i.e., Stub 1) to populate the Properties window. Then make the fol-
lowing changes: 

a. Ensure the 2 pt Description option is not selected.
b. EnterW in theWidth field. Then press Enter or Tab.
c. Enter S in the Height field. Then press Enter or Tab to open the Add Variable win-

dow.

Create the Model 1-32
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d. Ensuremil is selected from the Unit drop-down menu and 4.8 is entered in the
Value field. Then clickOK to close the Add Variable window.

e. EnterW/2, -S/2 in the Center field and press Enter or Tab to accept the coordin-
ates.

Continue to Creating L2.

Creating L2
Complete these steps to create the object L2 and then parameterize the object.

Create the Model 1-33
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1. From the Layout tab, click Draw rectangle.

2. Click the lower-left corner of Stub 1 (i.e., 0, -4.8).
3. Press Tab to move the cursor to the Delta X coordinate field at the bottom of the Layout

Editor. Then enter 86.4 in the field.
4. Press Tab to move the cursor to the Delta Y coordinate field. Then type -4.8 in the field

and press Enter to complete the new rectangle.

5. Select the new object (i.e., L2) to populate the Properties window. Then make the fol-
lowing changes:

Create the Model 1-34
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a. Ensure the 2 pt Description option is not selected.
b. Enter L2 in theWidth field. Then press Enter or Tab to open the Add Variable win-

dow.

c. Selectmil from the Unit drop-down menu and ensure 86.4 is entered in the Value
field. Then clickOK to close the Add Variable window.

Create the Model 1-35
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d. EnterW in the Height field. Then press Enter or Tab.

e. Enter L2/2, -S-W/2 in the Center field and press Enter or Tab to accept the coordin-
ates.

Create the Model 1-36
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Continue to Creating Stub 2.

Creating Stub 2
Complete these steps to create the object Stub 2 and then parameterize the object.

Create the Model 1-37
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1. From the Layout tab, click Draw rectangle.

2. Click the upper-right corner of L1 (i.e., 96, 4.8).
3. Press Tab to move the cursor to the Delta X coordinate field at the bottom of the Layout

Editor. Then enter -4.8.
4. Press Tab to move the cursor to the Delta Y coordinate field. Then type 4.8 in the field and

press Enter to complete the new rectangle.

5. Select the new object (i.e., Stub 2) to populate the Properties window. Then make the fol-
lowing changes:
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a. Ensure the 2 pt Description option is not selected.
b. EnterW in theWidth field. Then press Enter or Tab.
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c. Enter S in the Height field. Then press Enter or Tab.

d. Enter L1-W/2 , W+S/2 in the Center field and press Enter or Tab to accept the
coordinates.
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Continue to Creating L3.

Creating L3
Complete these steps to create the object L3 and then parameterize the object.
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1. From the Layout tab, click Draw rectangle.

2. Click the upper-right corner of Stub 2 (i.e., 96, 9.6).
3. Press Tab to move the cursor to the Delta X coordinate field at the bottom of the Layout

Editor. Then enter -86.4 in the field.
4. Press Tab to move the cursor to the Delta Y coordinate field. Then type 4.8 in the field and

press Enter to complete the new rectangle.

5. Select the new object (i.e., L3) to populate the Properties window. Then make the fol-
lowing changes:
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a. Ensure the 2 pt Description option is not selected.
b. Enter L2 in theWidth field. Then press Enter or Tab.
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c. EnterW in the Height field. Then press Enter or Tab.

d. Enter L1-L2/2, W+S+W/2 in the Center field and press Enter or Tab to accept the
coordinates.
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Continue to Creating Input 1.

Creating Input 1
Complete these steps to create the object Input 1 and then parameterize the object.
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1. From the Layout tab, click Draw rectangle.

2. Click the lower-left corner of L2 (i.e., 0, 0).
3. Press Tab to move the cursor to the Delta X coordinate field at the bottom of the Layout

Editor. Then enter -14.4 in the field.
4. Press Tab to move the cursor to the Delta Y coordinate field. Then type 4.8 in the field and

press Enter to complete the new rectangle.

5. Select the new object (i.e., Input 1) to populate the Properties window. Then make the fol-
lowing changes:

a. Ensure the 2 pt Description option is not selected.
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b. Enter Li in theWidth field. Then press Enter or Tab to open the Add Variable win-
dow.

c. Selectmil from the Unit drop-down menu and ensure 14.4 is entered in the Value
field. Then clickOK to close the Add Variable window.
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d. EnterW in the Height field. Then press Enter or Tab.

e. Enter -Li/2, W/2 in the Center field and press Enter or Tab to accept the coordin-
ates.

Create the Model 1-48

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Microstrip Filter

Continue to Creating Input 2.

Creating Input 2
Complete these steps to create the object Input 2 and then parameterize the object.
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1. From the Layout tab, click Draw rectangle.

2. Click the lower-right corner of L1 (i.e., 96, 0).
3. Press Tab to move the cursor to the Delta X coordinate field at the bottom of the Layout

Editor. Then enter 14.4 in the field.
4. Press Tab to move the cursor to the Delta Y coordinate field. Then type 4.8 in the field and

press Enter to complete the new rectangle.

5. Select the new object (i.e., Input 2) to populate the Properties window. Then make the fol-
lowing changes:
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a. Ensure the 2 pt Description option is not selected.
b. Enter Li in theWidth field. Then press Enter or Tab.
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c. EnterW in the Height field. Then press Enter or Tab.

d. Enter L1+Li/2, W/2 in the Center field and press Enter or Tab to accept the coordin-
ates.
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Continue to Creating Edge Ports.

Creating Edge Ports
Complete these steps to add two edge ports to the model.

1. To create the first port (i.e., Port1), first do any of the following to switch to edge selection
mode:
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l Press E to immediately enter Select Edgesmode.
l From the Layout tab, choose Select Edges from the cursor drop-down menu.
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l From Edit, click Select Edges.

Note: Once Select Edges is chosen, the cursor changes: a diagonal line
crosses the tip of the arrow.
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2. Click the left edge of Input 1 to select it.

3. To add the first port to the leftmost rectangle, do one of the following:
l From the Layout tab, select Create edge port.
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l From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Excitations and select Add Port.
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l From Draw, select Port > Create.
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l Right-click in the Layout Editor and select Port > Create.
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Note:

Once a port is created, it appears in the Project Manager > Project Tree > [act-
ive design folder] > Excitations folder.

4. Create the second port (i.e., Port2) by doing the following:
a. If appropriate, press E to re-enter Select Edgesmode.
b. Click the right edge of Input 2 to select it.
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c. From the Layout tab, select Create edge port.

Note:

In an earlierGetting Started Guide, the individual objects comprising the trace layer
were united into a single object. However, because this model is parametric, do not
unite the objects. Unlike the 3D Modeler used for conventional HFSS designs, the Lay-
out Editor does not maintain the full parametric history of the model construction. If the
trace objects are united, the parameters defined for the individual rectangles no longer
have any effect from the geometry. Once the individual rectangles are merged into a
complex polygon, the vertices of that polygon are defined using their absolute numer-
ical coordinates. Therefore, altering the design variables no longer has an effect on the
model because the variables are no longer used to define the united object. All of the
edges of the conducting objects in this exercise are coincident with their adjacent
objects' edges. Whether united or not, the trace objects behave like a single conducting
part and the solver treats the objects as a contiguous conducting part.

Continue to Setting Port Excitations.

Setting Port Excitations
In order to create meaningful results with the microstrip filter design, one edge port should act as
the filter input and the other as the filter output. By default, a 1 volt excitation at 0 degrees phase
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is applied to each edge port (i.e., Port1 and Port2). Complete these steps to modify the port
excitations to specify zero volts at Port2, allowing it to act as the filter output.

1. From HFSS 3D Layout, select Port Excitations to open the Port Excitations window.
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2. From the Port Excitations window, enter 0V in the Port2 Magnitude field.

3. ClickOK to close the Port Excitations window and return to the Layout Editor.
4. Save the project, either by navigating to File > Save or clicking the Save button on any of

the ribbons.

Continue to Creating an HFSS Analysis Setup.

Create the Model 1-63

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



PDF layout 1-64

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

Getting Started with HFSS 3D Layout: Microstrip Filter



2 - Analysis and Post-Processing
This chapter contains the following topics:

l Create HFSS Analysis Setup
l HFSS Bounding Box
l Create Planar EM Analysis Setup
l Validate and Analyze
l Review HFSS Convergence Data
l Plotting the HFSSMesh
l Create Comparative S-Parameter Plot
l Add and Analyze a Discrete Sweep
l Create and Animate a Current Overlay
l Create and Animate an E Field Overlay

Creating an HFSS Analysis Setup
Solution Setups are listed in the Project Manager window (i.e., expand the Project Tree > [act-
ive design folder] > Analysis). Complete these steps to add an HFSS Analysis setup solution
to this project using basic, initial meshing tools.

1. Open the Setup window by doing one of the following:
l From the Simulation ribbon tab, click HFSS > Advanced.
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l Right-click Analysis in the Project Manager window and select Add
HFSS Solution Setup > Advanced.
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l From HFSS 3D Layout, select Solution Setup > Add HFSS Solution Setup
> Advanced.
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2. Enter 20 in the Frequency field.
3. From the Fields area, check the Save fields box .
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4. Navigate to theOptions tab.

5. EnsureMixed Order is selected from theOrder of Basis Functions drop-down menu.
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6. ClickOK to close the HFSS Setup window and open the Edit Frequency Sweep window.

7. Ensure Interpolating is selected from the Sweep Type drop-down menu.
8. Ensure Linear Step is selected from the Distribution drop-down menu.
9. Enter the following parameters in the first row of the Frequency Sweeps table:

l 4 (GHz) in the Start field.
l 20 (GHz) in the End field.
l 0.02 (GHz) in the Step size field.
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10. ClickOK to add the interpolating sweep and close the Edit Frequency Sweep window.

Continue to Displaying the HFSS Bounding Box.

Displaying the HFSS Bounding Box
Complete these steps to display and then hide a bounding box around the complete design in
the Layout Editor.

1. From HFSS 3D Layout, select HFSS Extents to open the Set HFSS Model Extents win-
dow.
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2. Ensure theOpen Region box is checked and Radiation is selected.
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3. From the Dialectric area, enter 0 in the Horizontal Padding field.

4. Press Tab to activate the Apply button.
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5. Click Apply to save changes.
6. ClickOK to close the Set HFSS Model Extents window.
7. Navigate to the View ribbon. Then click HFSS Extents to display a bounding box around

the design in the Layout Editor.

8. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor con-
trols.

9. Repeat step 6 to hide the bounding box.

Continue to Setting Up a Planar EM Analysis Setup.

Setting Up a Planar EM Analysis
Solution Setups are listed in the Project Manager window (i.e., expand the Project Tree > [act-
ive design folder] > Analysis). To add a new solution setup to this project, follow these steps.
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1. Open the PlanarEMSetup window by doing one of the following:
l From the Simulation ribbon tab, click PlanarEM (Add Planar EM Solution
Setup).

l Right-click Analysis in the Project Manager window and click Add Planar EM
Solution Setup .
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l From HFSS 3D Layout, select Solution Setup > Add Planar EM Solution Setup.

2. From the PlanarEMSetup window > Mesh Selection area, do the following:
l Ensure Fixed Mesh is selected.
l Enter 20 in the Solution Frequency field.
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l Check the Use edge mesh check box.
l Select Absolute edge length and enter 1 mil in the field.
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3. Navigate to the Advanced tab.

4. From the Defeaturing area, ensure the Form polygon unions before meshing box is
checked.

5. ClickOK to close the PlanarEMSetup window and open the Edit Frequency Sweep win-
dow.
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6. Ensure Interpolating is selected from the Sweep Type drop-down menu.
7. Ensure Linear Step is selected from the Distribution drop-down menu.
8. Enter the following parameters in the first row of the Frequency Sweeps table:

l 4.0 (GHz) in the Start field.
l 20.0 (GHz) in the End field.
l 0.02 (GHz) in the Step size field.
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9. ClickOK to add the interpolating sweep and close the Edit Frequency Sweep window.

Continue to Validating and Analyzing the Design.

Validating and Analyzing the Design
Complete these steps to validate the active design and analyze both the HFSS and Planar
EM setups.

1. From the Simulation ribbon tab, click Validate to open the Validation Check window.
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Assuming the design is valid, the Validation Check window will display the following res-
ult.
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2. Click Close.

Note:

If the validation check detects any errors or warnings, view detailed feedback in
theMessage Manager window.

3. Solve both the HFSS Analysis and Planar EM Analysis setups, and their associated
sweeps, by doing one of the following:

Note:

To run an individual analysis, either select the setup in the Project Manager win-
dow and click Analyze in the Simulation ribbon, or right-click the setup and
select Analyze.
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l Right-click Analysis in the Project Manager window and select Analyze.

l From the Simulation ribbon tab, click Analyze.

Continue to Viewing Convergence History.

Viewing Convergence History
Complete these steps to view the active design's analysis convergence history.
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1. From the Project Manager window, right-click the HFSS Setup (i.e., Setup1) and select
Convergence to open the Solutions window.
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2. Select Plot.

3. Click Close.

Continue to Plotting the HFSS Mesh.

Plotting the HFSS Mesh
Complete these steps to plot and view a mesh of the HFSS Setup solution.

1. From the Project Manager window, right-click Field Overlays and select Plot Mesh to
open the Create Mesh Plot window.
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2. Under the Nets and Layers tab, check the Trace and Sub1 boxes to only plot the mesh
on those layers.

3. Click Done to close the Create Mesh Plot window and display the mesh for the Setup1 :
Last Adaptive solution in the Layout Editor.
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Note:

To change a mesh, from the Project Manager window, expand Field Overlays
> MeshPlots. Then right-click the mesh (e.g.,Mesh1) and select Reassign.
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4. From the Project Manager window, expand Field Overlays. Then right-clickMeshPlots
and selectModify Attributes to open theMeshPlots window.
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5. Either click+drag the Transparency scale marker or enter 60 in the field to improve the
visibility of the mesh lines (i.e., element edges).

6. Click Apply. Then click Close to return to the Layout Editor.
7. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor con-

trols.
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8. From the Project Manager window, right-click the mesh (e.g.,Mesh1) and select Plot
Visibility to remove the adjacent check mark and hide the mesh.

Continue to Creating the S-Parameter Plot.

Creating the S-Parameter Plot
Complete these steps to create an S-Parameter plot with four traces, two each, from the HFSS
and Planar EM analyse, then compare the result of the solution types.

Analysis and Post-Processing 2-29

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Microstrip Filter

1. From the Results ribbon tab, select Standard Report > 2D to open the Report window.

2. Ensure the following settings are selected:
l From the Context area, Setup1 : Sweep1 is selected from the Solution drop-
down menu.

l Sweep is selected from the Domain drop-down menu.
l From the Trace tab, S Parameter is selected from the Category list.
l dB is selected from the Function list.
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3. Ctrl+click to select S(Port1,Port1) and S(Port1,Port2) from theQuantity list.

4. Click New Report and the following plot appears. However, do not close the Report win-
dow.
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5. From the Context area, select PlanarEMSetup1 : Sweep1from the Solution drop-down
menu.

6. Click Add Trace.
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7. Click Close to view the new plot.

8. Click elsewhere in the View window to deselect the traces.
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9. Right-click within the View window and select Add Note to open the Add Note window.
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10. Enter the following note in the Add Note field:
l Type HFSS and Planar EM and press Enter.
l Type Results Comparison.
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11. ClickOK to close the Add Note window and add the note to the plot.
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12. Drag the note and legend to a desirable location.
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Note:

Both solutions demonstrate the bandstop behavior over the range of about 10 to 17
GHz. The only significant difference is in the magnitude of the three minimal points
along the traces (at 8.75, 12.5, and 15.2 GHz).

Continue to Adding and Analyzing a Discrete Sweep.

Adding and Analyzing a Discrete Sweep
In HFSS 3D Layout designs, surface current results are only available for the last pass of an
adaptive mesh or for discrete sweeps. Before viewing surface current results from the con-
ducting layers, follow these steps to define a discrete sweep with results at two frequencies (one
at a low pass-through frequency and one in the middle of the bandstop range) under the Planar
EM analysis setup.

1. From the Project Manager window, right-click the Planar EM analysis setup (i.e.,
PlanarEMSetup1) and select Add Frequency Sweep to open the Add Frequency
Sweep window.
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2. From the Edit Frequency Sweep window, do the following:
l Select Discrete from the Sweep Type drop-down menu.
l From the Frequency Sweeps table, select Single Point from the Distribution
drop-down menu.

l Enter 4 (GHz) in the Start field.
l Click Add Below.
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l In the new row, enter 14 (GHz) in the Start column.
l From theOptions area, check theGenerate surface current box.

3. ClickOK to add the discrete sweep and close the Edit Frequency Sweep window.
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4. From the Project Manager window, expand PlanarEMSetup1 and right-click the chosen
sweep (e.g., Sweep2). Then select Analyze.

Continue to Creating and Animating the Current Overlay.

Creating and Animating the Current Overlay
Complete these steps to create and animate the current overlay.

1. From theWindowmenu, select Layout (i.e., 1 microstrip_example - EMDesign1 - Lay-
out) to return to the Layout Editor.
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2. From the Project Manager window, right-click Field Overlays and select Plot PEM
Fields >Mag_SurfaceJ to open the Create Field Plot window.

3.  From the Create Field Plot window, ensure the following settings were selected by
default:
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l PlanarEMSetup1 : Sweep2 is selected from the Solution drop-down menu.
l 4GHz is selected from the Freq drop-down menu in the Intrinsic Variables area.
l Mag_SurfaceJ is selected from theQuantity list.
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4. Under the Nets and Layers tab, check the Trace andGND boxes.
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5. Click Done to close the Create Field Plot window and view the J Surf plot from the Lay-
out Editor.

6. Double-click the J Surf [A/m] plot legend to access the plot settings.
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7. Navigate to the Scale tab.

8. Ensure 10 is entered in the Num. Division field.
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9. Make the following changes:
l Select Log for a logarithmic scale.
l From the Number Format area, select Decimal from the Type drop-down menu.
l Enter 2 in the Precision field.
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10. Click Apply to save changes. Then click Close to return to the J Surf plot at the Layout
Editor.

11. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor con-
trols.
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12. From the Project Manager window, expand J Surf. Then right-clickMag_SurfaceJ1 and
selectModify Plot to open theModify Field Plot window.
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13. Select 14GHz from the Freq drop-down menu in the Intrinsic Variables area.
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14. Click Apply. Then click Done to close the window and return to the Layout Editor.
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15. From the Project Manager window, right-clickMag_SurfaceJ1 and select Animate to
open the Create Animation Setup window.

16. From the Create Animation Setup window, ensure the following settings were selected
by default:

l Single variable and Phase are selected from the drop-down menus.

l 0deg is entered in the Start field.

l 170deg is entered in the Stop field.

l 17 is entered in the Steps field.
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17. ClickOK to close the Create Animation Setup window, open an animation control panel,
and start the animation in the Layout Editor.
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18. Use the animation controls to reverse, stop, and change the speed of the animation,
among other settings.

19. From the animation control panel, click Close to end the animation.
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20. Before continuing, navigate to the Project Manager window. Then right-clickMag_Sur-
faceJ1 and select Plot Visibility to remove the adjacent check mark and hide the overlay.

Continue to Creating and Animating an E Field Overlay.

Creating and Animating an E Field Overlay
Complete these steps to create and animate the an E Field overlay.

1. From the Project Manager window, right-click Field Overlays and select Plot Fields > E
>Mag_E to open the Create Field Plot window.
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2.  From the Create Field Plot window, ensure the following settings were selected by
default:

l Setup1 : Last Adaptive is selected from the Solution drop-down menu.
l 0deg is selected from the Phase drop-down menu in the Intrinsic Variables area.
l Mag_E is selected from theQuantity list.
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3. Under the Nets and Layers tab, check the Trace andGND boxes.
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4. Click Done to close the Create Field Plot window and view the E Field plot from the Lay-
out Editor.
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5. Double-click the E Field [V/m] plot legend to access the plot settings.
6. Navigate to the Scale tab.

7. Ensure 10 is entered in the Num. Division field.
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8. Make the following changes:
l Select Log for a logarithmic scale.
l From the Number Format area, select Decimal from the Type drop-down menu.
l Enter 2 in the Precision field.
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9. Click Apply.
10. Click Close to return to the E Field plot at the Layout Editor.
11. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor con-

trols.
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12. From the Project Manager window, right-clickMag_E1 and select Animate to open the
Select Animation window.

13. ClickOK to select the only available option (i.e., Animation1 (Swept variable Phase)),
which was defined in the previous step. The Select Animation window closes, an anim-
ation control panel opens, and the animation begins in the Layout Editor.
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14. Use the animation controls to reverse, stop, and change the speed of the animation,
among other settings.

15. From the animation control panel, click Close to end the animation.
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16. From the Project Manager window, right-clickMag_E1 and select Plot Visibility to
remove the check mark and hide the mesh.

Continue to Optional Challenge Exercise.

Optional Challenge Exercise: Experimenting With Para-
meterization
Since the geometry of this model is parameterized, experiment with how easy it is to alter the
geometry and reanalyze the results. Parameterization is a convenient way to perform analyses
to see the effects of different design variations. Complete these steps to locate and edit the
design variables, as chosen.
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1. From HFSS 3D Layout, select Design Properties to open the Properties window.
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2. Navigate to the Local Variables tab.

3. The Local Variables tab contains the variables that can be defined by the user, listed in
the order in which they are defined. Enter a different number in the Value fields to alter the
dimensions of the model, as chosen.

Warning:

Do not to make excessive adjustments to the variables. The ground plane is
drawn at a fixed size and the trace objects must remain in the perimeter of the
ground plane.

4. Click Apply to update the model in the Layout Editor.
5. ClickOK to close the Properties window.
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6. From the Project Manager window, right-click Analysis and select Analyze to rerun all
analysis setups of the altered model.

7. Observe any changes in the S-parameter plot once the solution is finished.

Note:

The user can also automate the selection of design property values to achieve targeted
results. For more information, search for "optimization" or "design of experiments" in
the Help.

Congratulations, the HFSS 3D Layout microstrip filter getting started guide is complete.
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